aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdbusaddons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdbusaddons/APKBUILD')
-rw-r--r--community/kdbusaddons/APKBUILD50
1 files changed, 28 insertions, 22 deletions
diff --git a/community/kdbusaddons/APKBUILD b/community/kdbusaddons/APKBUILD
index 1fb40a95c82..a1a7b1f340f 100644
--- a/community/kdbusaddons/APKBUILD
+++ b/community/kdbusaddons/APKBUILD
@@ -1,40 +1,46 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kdbusaddons
-pkgver=5.67.0
-pkgrel=1
+pkgver=6.1.0
+pkgrel=0
pkgdesc="Addons to QtDBus"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
-makedepends="extra-cmake-modules qt5-qttools-dev doxygen shared-mime-info"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdbusaddons-$pkgver.tar.xz"
+makedepends="
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ shared-mime-info
+ samurai
+ "
+checkdepends="dbus"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Requires running dbus-daemon
-
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
+_repo_url="https://invent.kde.org/frameworks/kdbusaddons.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdbusaddons-$pkgver.tar.xz"
build() {
- cd "$builddir"/build
- cmake "$builddir" \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
- make
+ cmake --build build
}
check() {
- cd "$builddir"/build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ dbus-run-session -- ctest --test-dir build --output-on-failure
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="84f46df5648a0868aa82465072993b91c0448d313c5225184adc4d3760e56ef4af72cc4b0acb84836df1025bc01c54c6813f415f9401d073101d72d9ef6f6972 kdbusaddons-5.67.0.tar.xz"
+
+sha512sums="
+924d21179c624fdeed9de230c22b12d4682980b8578e81a8473bb95a1d251a104d5d6dd7e999e01caf5652a60a6b78ad2baf07e98d1d1d60c5ed2c4c7e6a844d kdbusaddons-6.1.0.tar.xz
+"