aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdbusaddons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdbusaddons/APKBUILD')
-rw-r--r--community/kdbusaddons/APKBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/community/kdbusaddons/APKBUILD b/community/kdbusaddons/APKBUILD
index f9c1dfab8c1..a1a7b1f340f 100644
--- a/community/kdbusaddons/APKBUILD
+++ b/community/kdbusaddons/APKBUILD
@@ -1,20 +1,32 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kdbusaddons
-pkgver=5.88.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Addons to QtDBus"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
-makedepends="extra-cmake-modules qt5-qttools-dev doxygen shared-mime-info"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdbusaddons-$pkgver.tar.xz"
+makedepends="
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ shared-mime-info
+ samurai
+ "
+checkdepends="dbus"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Requires running dbus-daemon
+_repo_url="https://invent.kde.org/frameworks/kdbusaddons.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdbusaddons-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -22,13 +34,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ dbus-run-session -- ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-103ff1d382231551263a8d2b4a4519d99bd92ff4955cc19eacce5d63db930af828d7f23117fe975509ec447d889d154d75deb63f10ec1482ae4cb5f49f7cd830 kdbusaddons-5.88.0.tar.xz
+924d21179c624fdeed9de230c22b12d4682980b8578e81a8473bb95a1d251a104d5d6dd7e999e01caf5652a60a6b78ad2baf07e98d1d1d60c5ed2c4c7e6a844d kdbusaddons-6.1.0.tar.xz
"