aboutsummaryrefslogtreecommitdiffstats
path: root/community/kde-cli-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kde-cli-tools/APKBUILD')
-rw-r--r--community/kde-cli-tools/APKBUILD39
1 files changed, 19 insertions, 20 deletions
diff --git a/community/kde-cli-tools/APKBUILD b/community/kde-cli-tools/APKBUILD
index 7b3e9ac063b..850112e29fe 100644
--- a/community/kde-cli-tools/APKBUILD
+++ b/community/kde-cli-tools/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kde-cli-tools
-pkgver=5.21.5
+pkgver=6.0.3
pkgrel=0
pkgdesc="Tools based on KDE Frameworks 5 to better interact with the system"
# armhf blocked by extra-cmake-modules
-# s390x blocked by libksysguard
-arch="all !armhf !s390x !mips64"
+arch="all !armhf"
url="https://invent.kde.org/plasma/kde-cli-tools"
license="(GPL-2.0-only OR GPL-3.0-only) AND GPL-2.0-or-later AND GPL-2.0-only AND LGPL-2.1-only"
makedepends="
extra-cmake-modules
- kactivities-dev
kcmutils-dev
kconfig-dev
kdeclarative-dev
@@ -19,14 +20,14 @@ makedepends="
kdoctools-dev
ki18n-dev
kiconthemes-dev
- kinit-dev
kio-dev
+ kparts-dev
kservice-dev
kwindowsystem-dev
- plasma-workspace-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
- qt5-qtx11extras-dev
+ plasma-activities-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
checkdepends="xvfb-run"
@@ -34,29 +35,27 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kde-cli-tools-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # Broken
-
-# Workaround a circular dependency https://gitlab.alpinelinux.org/alpine/aports/-/issues/11785
-install_if="plasma-workspace"
+_repo_url="https://invent.kde.org/plasma/kde-cli-tools.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kde-cli-tools-$pkgver.tar.xz"
+# Broken
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-20859f88044c6af84ba4b666b803a6a3a4fbe33748495d9c186fc0739e7b5464b234166cef4d03f0dd44540919eca4f3ea8a1f5ac7b54d480cc9dadeaa0ec3fc kde-cli-tools-5.21.5.tar.xz
+1090267afd99929ddf7eeeb17f9f39cb6bba0e8ef441d22a9c64301b9ff623a23bf5d2410fdec184408b8ed7d83622cee909c6e7b23299ad95ac58eae7fc0cf5 kde-cli-tools-6.0.3.tar.xz
"