aboutsummaryrefslogtreecommitdiffstats
path: root/community/kde-dev-scripts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kde-dev-scripts/APKBUILD')
-rw-r--r--community/kde-dev-scripts/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/kde-dev-scripts/APKBUILD b/community/kde-dev-scripts/APKBUILD
new file mode 100644
index 00000000000..0ece9049111
--- /dev/null
+++ b/community/kde-dev-scripts/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
+pkgname=kde-dev-scripts
+pkgver=24.02.2
+pkgrel=0
+# armhf blocked by extra-cmake-modules
+arch="all !armhf !s390x"
+url="https://kde.org/applications/development/"
+pkgdesc="Scripts and setting files useful during development of KDE software"
+license="GPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="
+ extra-cmake-modules
+ kdoctools-dev
+ samurai
+ "
+_repo_url="https://invent.kde.org/sdk/kde-dev-scripts.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kde-dev-scripts-$pkgver.tar.xz"
+# No code to test
+options="!check"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+6cc003798da5ab87442625155bfa5176299100e78827b7644dee66e381e43a06e4984d1da7115eac83cf4f4a8d54052c7f136b46b52e3013752661f0748e57d6 kde-dev-scripts-24.02.2.tar.xz
+"