aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdecoration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdecoration/APKBUILD')
-rw-r--r--community/kdecoration/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/kdecoration/APKBUILD b/community/kdecoration/APKBUILD
index 2b26e390344..3591f14927b 100644
--- a/community/kdecoration/APKBUILD
+++ b/community/kdecoration/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kdecoration
-pkgver=5.25.2
+pkgver=6.0.4
pkgrel=0
pkgdesc="Plugin based library to create window decorations"
arch="all !armhf"
@@ -10,7 +13,7 @@ license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
kcoreaddons-dev
ki18n-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
@@ -22,8 +25,9 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kdecoration-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/kdecoration.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kdecoration-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -34,8 +38,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run -a ctest --test-dir build --output-on-failure
}
package() {
@@ -43,5 +46,5 @@ package() {
}
sha512sums="
-2be02149d6da7690aa0802510107291c481106368df3da68b12c5428193cf01fb4769f853526dfd0eb9a3a3641e057c66f34ff703cd11e843271f7f4a4c09c37 kdecoration-5.25.2.tar.xz
+a27f97b5bdec32702e9aee66b81d11da340dcd12048a1a193f35419e45032bffbffc5e49bd65648314db6b0513e041b29c18941bf117474c72698fd45a60fbfc kdecoration-6.0.4.tar.xz
"