aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdecoration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdecoration/APKBUILD')
-rw-r--r--community/kdecoration/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/community/kdecoration/APKBUILD b/community/kdecoration/APKBUILD
index bfeb4ff974d..04905f57b71 100644
--- a/community/kdecoration/APKBUILD
+++ b/community/kdecoration/APKBUILD
@@ -1,18 +1,23 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kdecoration
-pkgver=5.23.4
+pkgver=6.0.3
pkgrel=0
pkgdesc="Plugin based library to create window decorations"
arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
+ kcoreaddons-dev
ki18n-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
checkdepends="xvfb-run"
@@ -20,25 +25,26 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kdecoration-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/kdecoration.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kdecoration-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run -a ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-17ea89c7eb0cad35b46af401ef2e38243a711c5ee9f3c26b86bec65dab86b26ac19a8d29fe523c45e3f8ed7908f3fb3515e58a15466cd9f6e879a3c577667ce9 kdecoration-5.23.4.tar.xz
+955f943384ad551cf77af1e1848fb732e9612dafb104f5c4f14c8d54ae3ac7a17327c811053d4e741cd71cf4387145721585f45721c3faaeb354eecd1e60dae3 kdecoration-6.0.3.tar.xz
"