aboutsummaryrefslogtreecommitdiffstats
path: root/community/kded/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kded/APKBUILD')
-rw-r--r--community/kded/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/kded/APKBUILD b/community/kded/APKBUILD
index b3e7e653def..2089c7930ef 100644
--- a/community/kded/APKBUILD
+++ b/community/kded/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kded
-pkgver=5.86.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Extensible deamon for providing system level services"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -13,35 +16,36 @@ depends_dev="
kcrash-dev
kdbusaddons-dev
kservice-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
kdoctools-dev
+ samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kded-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kded.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kded-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
-
package() {
DESTDIR="$pkgdir" cmake --install build
# We don't ship systemd
rm -r "$pkgdir"/usr/lib/systemd
}
+
sha512sums="
-512958cf61a2a4d31d2a2e51536757b6ab92fbfa5af1d7f979efcf9a543a9bcc198687ed64ee8d6a293de23d00520b0d9cf4ac11552d2268234a65559ec04846 kded-5.86.0.tar.xz
+d0832122f3d81ffb79079881cd735230b9d3e4cbaef2b2cc5cc35bfec872145e8ba85b29d7ac3eda3f2966256d1a3c8a8d7df50c3c096094dc3344e432b6408e kded-6.1.0.tar.xz
"