aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdeedu-data/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdeedu-data/APKBUILD')
-rw-r--r--community/kdeedu-data/APKBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/community/kdeedu-data/APKBUILD b/community/kdeedu-data/APKBUILD
index 2e8226c8ce9..47e4d8d75be 100644
--- a/community/kdeedu-data/APKBUILD
+++ b/community/kdeedu-data/APKBUILD
@@ -1,15 +1,25 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdeedu-data
-pkgver=22.08.0
+pkgver=24.02.2
pkgrel=0
-arch="noarch !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="noarch !armhf"
url="https://kde.org/applications/education"
pkgdesc="Common data for KDE Edu applications"
license="GPL-2.0-only"
-makedepends="extra-cmake-modules samurai"
+makedepends="
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
+_repo_url="https://invent.kde.org/education/kdeedu-data.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/kdeedu-data-$pkgver.tar.xz"
-options="!check" # No code to test"
+# No code to test
+options="!check"
build() {
cmake -B build -G Ninja \
@@ -20,9 +30,9 @@ build() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-a8199528429150cfbb5cd02646e35bfb1a83919406781a2c5a42364076216e73789033bf57cc5577cf4a20805dd8f291234315619e9943c2c8ac0c2bc1114bdf kdeedu-data-22.08.0.tar.xz
+bfbaf93b23afeb42dbf3d6fa28f624af0f8d5053283a1fef0786e564222378e1ff264145b338423c2275f0c789f50755f3983c0ff92e3ac3adeaf760c8a297d2 kdeedu-data-24.02.2.tar.xz
"