aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdeedu-data/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdeedu-data/APKBUILD')
-rw-r--r--community/kdeedu-data/APKBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/community/kdeedu-data/APKBUILD b/community/kdeedu-data/APKBUILD
index f46f382b62d..47e4d8d75be 100644
--- a/community/kdeedu-data/APKBUILD
+++ b/community/kdeedu-data/APKBUILD
@@ -1,15 +1,25 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdeedu-data
-pkgver=22.04.0
-pkgrel=1
-arch="noarch !armhf" # armhf blocked by extra-cmake-modules
+pkgver=24.02.2
+pkgrel=0
+# armhf blocked by extra-cmake-modules
+arch="noarch !armhf"
url="https://kde.org/applications/education"
pkgdesc="Common data for KDE Edu applications"
license="GPL-2.0-only"
-makedepends="extra-cmake-modules samurai"
+makedepends="
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
+_repo_url="https://invent.kde.org/education/kdeedu-data.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/kdeedu-data-$pkgver.tar.xz"
-options="!check" # No code to test"
+# No code to test
+options="!check"
build() {
cmake -B build -G Ninja \
@@ -20,9 +30,9 @@ build() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-8a9d8b07fad4659e11259c081c4d463882959127505d3d996b3bdda6ca4e57c235e1abf80cdd4ffe55272b2413bce446725c71c9344029955dcf86c5b2394863 kdeedu-data-22.04.0.tar.xz
+bfbaf93b23afeb42dbf3d6fa28f624af0f8d5053283a1fef0786e564222378e1ff264145b338423c2275f0c789f50755f3983c0ff92e3ac3adeaf760c8a297d2 kdeedu-data-24.02.2.tar.xz
"