aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdenetwork-filesharing/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdenetwork-filesharing/APKBUILD')
-rw-r--r--community/kdenetwork-filesharing/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/kdenetwork-filesharing/APKBUILD b/community/kdenetwork-filesharing/APKBUILD
index 344696517ab..c6a5d4d0700 100644
--- a/community/kdenetwork-filesharing/APKBUILD
+++ b/community/kdenetwork-filesharing/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdenetwork-filesharing
-pkgver=21.08.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# armhf, s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/internet/"
pkgdesc="Properties dialog plugin to share a directory with the local network"
license="GPL-2.0-only OR GPL-3.0-only"
@@ -19,15 +21,17 @@ makedepends="
ki18n-dev
kio-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
+ qcoro-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdenetwork-filesharing-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/network/kdenetwork-filesharing.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdenetwork-filesharing-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DSAMBA_INSTALL=OFF
@@ -35,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -44,5 +47,5 @@ package() {
}
sha512sums="
-d85697ada8d28469e554729c1ec93ae83ba7acd392b2910343642878d5d5ca14404b8bfe518ddee1a5762d24330675a3eb96e0b151711fd7480a37487290a925 kdenetwork-filesharing-21.08.1.tar.xz
+27c4cd378b85a6f1ba7e27bd8df03436557103c2390c5c7a8eef3d3616e1a2e4cfaf343ba33ba7840574af44fc1b53aaecee192c03d5981fc5438daa31bdc9cf kdenetwork-filesharing-24.02.2.tar.xz
"