aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdenetwork-filesharing/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdenetwork-filesharing/APKBUILD')
-rw-r--r--community/kdenetwork-filesharing/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/kdenetwork-filesharing/APKBUILD b/community/kdenetwork-filesharing/APKBUILD
index 689c352379c..c6a5d4d0700 100644
--- a/community/kdenetwork-filesharing/APKBUILD
+++ b/community/kdenetwork-filesharing/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdenetwork-filesharing
-pkgver=22.04.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# armhf, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/internet/"
pkgdesc="Properties dialog plugin to share a directory with the local network"
license="GPL-2.0-only OR GPL-3.0-only"
@@ -19,12 +21,13 @@ makedepends="
ki18n-dev
kio-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
+ qcoro-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdenetwork-filesharing-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/network/kdenetwork-filesharing.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdenetwork-filesharing-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -36,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +47,5 @@ package() {
}
sha512sums="
-bdd7eafae0e433e1820661e2d1fc64a08d98c9e2fccaf4bed22d7f5604bd5bf66f13c412e458f59aeeea6bca56719525fb9a312b62f5a163558e87869a7d9c39 kdenetwork-filesharing-22.04.1.tar.xz
+27c4cd378b85a6f1ba7e27bd8df03436557103c2390c5c7a8eef3d3616e1a2e4cfaf343ba33ba7840574af44fc1b53aaecee192c03d5981fc5438daa31bdc9cf kdenetwork-filesharing-24.02.2.tar.xz
"