aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdepim-addons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdepim-addons/APKBUILD')
-rw-r--r--community/kdepim-addons/APKBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/community/kdepim-addons/APKBUILD b/community/kdepim-addons/APKBUILD
index b6a98a1d3b5..067da2497b7 100644
--- a/community/kdepim-addons/APKBUILD
+++ b/community/kdepim-addons/APKBUILD
@@ -1,11 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdepim-addons
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
+arch="all !armhf !armv7 !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Addons for KDE PIM applications"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
@@ -21,6 +24,7 @@ makedepends="
grantlee-dev
grantleetheme-dev
incidenceeditor-dev
+ kaddressbook-dev
kcalendarcore-dev
kcalutils-dev
kconfig-dev
@@ -50,21 +54,26 @@ makedepends="
messagelib-dev
pimcommon-dev
prison-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
+ samurai
syntax-highlighting-dev
"
checkdepends="
+ dbus
drkonqi
- xvfb-runi
+ xvfb-run
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdepim-addons-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # Require OpenGL and running dbus
+_repo_url="https://invent.kde.org/pim/kdepim-addons.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdepim-addons-$pkgver.tar.xz"
+# net required to download Rust crates
+# tests are broken and hang
+options="!check net"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DKDEPIMADDONS_BUILD_EXAMPLES=OFF
@@ -72,8 +81,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ dbus-run-session xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -81,5 +89,5 @@ package() {
}
sha512sums="
-3813f3d9dff60158ca14f4afb8b904a5df9f1d54d180767846be2085869ceeb60ce13b6b017cc8297d8d1bdbb4d0fd7e155701c6babaa7c4c8cfb44d658864e7 kdepim-addons-21.04.3.tar.xz
+484e844b3e1494b3d86b77e16f7bfb9b83a8ceea3be697431d3c72698ad888b1e14522b92c6b7db39500e1c66ee0952c6df3c8146691432f6e0ec6f0e26f4dbd kdepim-addons-24.02.2.tar.xz
"