aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdesdk-thumbnailers/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdesdk-thumbnailers/APKBUILD')
-rw-r--r--community/kdesdk-thumbnailers/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/kdesdk-thumbnailers/APKBUILD b/community/kdesdk-thumbnailers/APKBUILD
index 882632a00a8..455011a9231 100644
--- a/community/kdesdk-thumbnailers/APKBUILD
+++ b/community/kdesdk-thumbnailers/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdesdk-thumbnailers
-pkgver=21.08.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/development/"
pkgdesc="Plugins for the thumbnailing system"
license="GPL-2.0-only OR GPL-3.0-only"
@@ -15,23 +17,24 @@ makedepends="
kconfig-dev
ki18n-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdesdk-thumbnailers-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/sdk/kdesdk-thumbnailers.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdesdk-thumbnailers-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -39,5 +42,5 @@ package() {
}
sha512sums="
-20fa19e494cfba2905fc77c1997fb2679915c90ccd822613c720b495e58d7ae1d92597248b290c12ae8f6ff2c5a8faee6198ce4173a48afbe9026b862e3820c9 kdesdk-thumbnailers-21.08.2.tar.xz
+b1cb620d4abca0aabdc8ad626ffcaf53fb554e1f36b83ca252c4a1b21d8a3fba6096e1d91617329544959a52133288e1278f0666c3bc58fc68da744e3f991a66 kdesdk-thumbnailers-24.02.2.tar.xz
"