aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdesu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdesu/APKBUILD')
-rw-r--r--community/kdesu/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/kdesu/APKBUILD b/community/kdesu/APKBUILD
index 10385d4c848..fa41938997a 100644
--- a/community/kdesu/APKBUILD
+++ b/community/kdesu/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kdesu
-pkgver=5.88.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Integration with su for elevated privileges"
# armhf blocked by extra-cmake-modules
@@ -17,19 +20,21 @@ depends_dev="
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdesu-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kdesu.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdesu-$pkgver.tar.xz"
# Since the goal of this library is to elevate privileges, suid being needed should be obvious
options="suid"
[ "$CARCH" = "ppc64le" ] && options="$options !check" # kdesutest is broken
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -37,13 +42,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure -E "kdesutest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-faca2f4d8b406efe447b100a8c8d115b4e598d7bd2887b77464110a71b7d7c37f742da177a3923037e3fec61be7da8ca9bf04a5a07e7a3e4022edbfcd3536231 kdesu-5.88.0.tar.xz
+6ea4e6ae3f648915e8ad63d605e56fd504954138e8c663e0d41fbe1a2bd9da738f5b9024e1be631171fb38b1af7eff1af2db11cd5418a8602862a81a2da5ed2d kdesu-6.1.0.tar.xz
"