aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdesu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdesu/APKBUILD')
-rw-r--r--community/kdesu/APKBUILD44
1 files changed, 31 insertions, 13 deletions
diff --git a/community/kdesu/APKBUILD b/community/kdesu/APKBUILD
index 74289f608c7..fa41938997a 100644
--- a/community/kdesu/APKBUILD
+++ b/community/kdesu/APKBUILD
@@ -1,36 +1,54 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kdesu
-pkgver=5.82.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Integration with su for elevated privileges"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only"
-depends_dev="kcoreaddons-dev ki18n-dev kservice-dev kpty-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
+depends_dev="
+ kcoreaddons-dev
+ ki18n-dev
+ kpty-dev
+ kservice-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
checkdepends="xvfb-run"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kdesu.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdesu-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-lang"
# Since the goal of this library is to elevate privileges, suid being needed should be obvious
options="suid"
+[ "$CARCH" = "ppc64le" ] && options="$options !check" # kdesutest is broken
+
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure -E "kdesutest"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-6d4cbbc783959d093f59221dc0cf7862f30444878a32475976519b443713e8ea1f154c8a62f7cf4468e807ebd983afb037211d5641335822037bad04501552ae kdesu-5.82.0.tar.xz
+6ea4e6ae3f648915e8ad63d605e56fd504954138e8c663e0d41fbe1a2bd9da738f5b9024e1be631171fb38b1af7eff1af2db11cd5418a8602862a81a2da5ed2d kdesu-6.1.0.tar.xz
"