aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdf/APKBUILD')
-rw-r--r--community/kdf/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/community/kdf/APKBUILD b/community/kdf/APKBUILD
index 22ed54c67e6..638e98d6e94 100644
--- a/community/kdf/APKBUILD
+++ b/community/kdf/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdf
-pkgver=22.08.0
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
arch="all !armhf"
@@ -18,13 +21,15 @@ makedepends="
kiconthemes-dev
kio-dev
knotifications-dev
+ kstatusnotifieritem-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdf-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kdf.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdf-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -35,8 +40,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -44,5 +48,5 @@ package() {
}
sha512sums="
-79faf5eb88637fb916cbffb2dcf5c3e3be4adbf962b60b4c2432962832a621cf197021a6c783969326862ee7dfd6cf984500332d938e214eacc2fcf870516c33 kdf-22.08.0.tar.xz
+101ea4867ceb11587303e7f928e99dc253171c261f787a793fa8ea110a891113f83694e5649ebcd2186fa81fbfea608b1ea544b3a24759ea8222d8934b6bde18 kdf-24.02.2.tar.xz
"