aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdf/APKBUILD')
-rw-r--r--community/kdf/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/kdf/APKBUILD b/community/kdf/APKBUILD
index 63ed0cfd61f..638e98d6e94 100644
--- a/community/kdf/APKBUILD
+++ b/community/kdf/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdf
-pkgver=21.08.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/org.kde.kdf"
pkgdesc="View disk usage"
license="GPL-2.0-or-later"
@@ -19,24 +21,26 @@ makedepends="
kiconthemes-dev
kio-dev
knotifications-dev
+ kstatusnotifieritem-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdf-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kdf.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdf-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -44,5 +48,5 @@ package() {
}
sha512sums="
-01845ac865de39957b9e209b0d4a269d12df6ac7adede01c26ba52c243285d1041e63f41d8a85180c83f3a42bdd7d257299c3f3aeefef382076e9230ba8b1345 kdf-21.08.2.tar.xz
+101ea4867ceb11587303e7f928e99dc253171c261f787a793fa8ea110a891113f83694e5649ebcd2186fa81fbfea608b1ea544b3a24759ea8222d8934b6bde18 kdf-24.02.2.tar.xz
"