aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdf/APKBUILD')
-rw-r--r--community/kdf/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/kdf/APKBUILD b/community/kdf/APKBUILD
index 86c0962b5ad..638e98d6e94 100644
--- a/community/kdf/APKBUILD
+++ b/community/kdf/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdf
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/org.kde.kdf"
pkgdesc="View disk usage"
license="GPL-2.0-or-later"
@@ -19,13 +21,15 @@ makedepends="
kiconthemes-dev
kio-dev
knotifications-dev
+ kstatusnotifieritem-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdf-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kdf.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdf-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -36,8 +40,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +48,5 @@ package() {
}
sha512sums="
-b5fa744bc5805e3e3a3d704b31fcf0a8bc6916a1456c2916a488511fbd0b22ddddd69966bd5404abdf7f0d5fafb85a7e386e4282004920d8edec8e0eb9fa98cc kdf-22.04.2.tar.xz
+101ea4867ceb11587303e7f928e99dc253171c261f787a793fa8ea110a891113f83694e5649ebcd2186fa81fbfea608b1ea544b3a24759ea8222d8934b6bde18 kdf-24.02.2.tar.xz
"