aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdialog/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdialog/APKBUILD')
-rw-r--r--community/kdialog/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/kdialog/APKBUILD b/community/kdialog/APKBUILD
index 042b958d554..f1a4c42dcb1 100644
--- a/community/kdialog/APKBUILD
+++ b/community/kdialog/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdialog
-pkgver=21.12.1
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org/"
pkgdesc="A utility for displaying dialog boxes from shell scripts"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -18,22 +20,23 @@ makedepends="
knotifications-dev
ktextwidgets-dev
kwindowsystem-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdialog-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kdialog.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdialog-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -41,5 +44,5 @@ package() {
}
sha512sums="
-9d02322675043080aec6121703924edbda75665471833f970be21c52f396ac073e5d099f97a876ae3c41369ae7056afb23ab62743aa82800d31309812e2ce850 kdialog-21.12.1.tar.xz
+763966a314e5b3476b43c0647703afd37ff761b2a4b6e8cc2f270858dcbdba8233777674a54d31937c1f8222b2ff5549427b2803ad746dcfa931b851d0d302ad kdialog-24.02.1.tar.xz
"