aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdialog/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdialog/APKBUILD')
-rw-r--r--community/kdialog/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/kdialog/APKBUILD b/community/kdialog/APKBUILD
index e5ce2d04c82..35df5b32d86 100644
--- a/community/kdialog/APKBUILD
+++ b/community/kdialog/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdialog
-pkgver=21.08.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org/"
pkgdesc="A utility for displaying dialog boxes from shell scripts"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -18,22 +20,23 @@ makedepends="
knotifications-dev
ktextwidgets-dev
kwindowsystem-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdialog-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kdialog.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdialog-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -41,5 +44,5 @@ package() {
}
sha512sums="
-fbb323043be84fa57c52bad5d0955e1836d4ee3af26940cb68e659612ab9f278f5a730e2c97c535ead82f75478b1c8247fb21f3643d1588fc9ea698c8ca39399 kdialog-21.08.1.tar.xz
+4e839cd1abb764322575b7299a83adaa7a18a80aa4f57d45bcf536b06c827d62145d1aaf9e4623bc7a29011cc8015bf89297ec387922945f1a7061877438f0b1 kdialog-24.02.2.tar.xz
"