aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdiamond/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdiamond/APKBUILD')
-rw-r--r--community/kdiamond/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/kdiamond/APKBUILD b/community/kdiamond/APKBUILD
index c2a172498cc..b3a945610a3 100644
--- a/community/kdiamond/APKBUILD
+++ b/community/kdiamond/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kdiamond
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
pkgdesc="A single player puzzle game"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/kdiamond/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
@@ -23,15 +25,18 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kdiamond-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/kdiamond.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdiamond-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -42,5 +47,5 @@ package() {
}
sha512sums="
-bd39a7bb8fc99deb542606fb4df0ed4efaf3ef9a8332f6eeefcc18811f8ba970a1004a8f5bea4c7110ba9ace4682278846ea000e09a4a9805dae2c5dcb07fb6b kdiamond-21.12.1.tar.xz
+1226750784e2e1d60c263718a217c4e9b793bea0529b57bbd3d1d8f81db4688f5f28b8cd6b5d3787c636b7e59baa59acdde490219d876b5f26fdab2cf449b058 kdiamond-24.02.2.tar.xz
"