aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdiff3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdiff3/APKBUILD')
-rw-r--r--community/kdiff3/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/kdiff3/APKBUILD b/community/kdiff3/APKBUILD
new file mode 100644
index 00000000000..ca62c0d5eb4
--- /dev/null
+++ b/community/kdiff3/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-other
+pkgname=kdiff3
+pkgver=1.10.7
+pkgrel=0
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
+url="https://apps.kde.org/kdiff3/"
+pkgdesc="A file and folder diff and merge tool"
+license="GPL-2.0-or-later "
+makedepends="
+ boost-dev
+ extra-cmake-modules
+ kconfig5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kparts5-dev
+ kwidgetsaddons5-dev
+ qt5-qtbase-dev
+ samurai
+ "
+checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/sdk/kdiff3.git"
+source="https://download.kde.org/stable/kdiff3/kdiff3-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
+}
+
+check() {
+ xvfb-run ctest --test-dir build --output-on-failure
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+ab7ce8312014de200bcc613be1a28b384289f96be08d7f2e1e640b202cede3bbfeffa7b3e53b605f8edf9be2368d2aa6c6b5ee4501577ed8560ca1c4704802db kdiff3-1.10.7.tar.xz
+"