aboutsummaryrefslogtreecommitdiffstats
path: root/community/keepassxc-proxy-static/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/keepassxc-proxy-static/APKBUILD')
-rw-r--r--community/keepassxc-proxy-static/APKBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/community/keepassxc-proxy-static/APKBUILD b/community/keepassxc-proxy-static/APKBUILD
index e616e03f5a0..595abbd37be 100644
--- a/community/keepassxc-proxy-static/APKBUILD
+++ b/community/keepassxc-proxy-static/APKBUILD
@@ -2,28 +2,22 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=keepassxc-proxy-static
_projname=keepassxc-proxy-rust
-pkgver=0_git20220716
-_gitrev=5b993d10032651fd501d18cc4e60acca2fa33a46
-pkgrel=0
+pkgver=0.2.0
+pkgrel=1
pkgdesc="A statically linked proxy between Native Messaging browser extension and KeePassXC (for use with Flatpak)"
url="https://github.com/varjolintu/keepassxc-proxy-rust"
-# armhf, armv7, s390x: fails to build
-# riscv64: blocked by rust/cargo
+# armhf, armv7, riscv64, s390x: fails to build libc crate (SIGSEGV)
arch="all !armhf !armv7 !riscv64 !s390x"
license="GPL-3.0-or-later"
-makedepends="cargo"
+makedepends="cargo cargo-auditable"
install="$pkgname.post-install"
-source="https://github.com/varjolintu/keepassxc-proxy-rust/archive/$_gitrev/$_projname-$_gitrev.tar.gz
- update-deps.patch
+source="https://github.com/varjolintu/keepassxc-proxy-rust/archive/$pkgver/$_projname-$pkgver.tar.gz
keepassxc-proxy-install.in
"
-builddir="$srcdir/$_projname-$_gitrev"
+builddir="$srcdir/$_projname-$pkgver"
-export CARGO_PROFILE_RELEASE_CODEGEN_UNITS=1
-export CARGO_PROFILE_RELEASE_LTO="true"
export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
-export CARGO_PROFILE_RELEASE_PANIC="abort"
-export RUSTFLAGS="-C target-feature=+crt-static"
+export RUSTFLAGS="$RUSTFLAGS -C target-feature=+crt-static"
prepare() {
default_prepare
@@ -31,11 +25,11 @@ prepare() {
sed "s/@@VERSION@@/$pkgver/" "$srcdir"/keepassxc-proxy-install.in \
> "$srcdir"/keepassxc-proxy-install
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build --frozen --release
+ cargo auditable build --frozen --release
}
check() {
@@ -54,7 +48,6 @@ package() {
}
sha512sums="
-2f9be1f1792864d995f90e00ad84374107a0d35ee653a2259cb4ddba85abf13d2cbd7066ebec3ea929e58793de6be9b311cb729e03138f76917e3fb263312e6b keepassxc-proxy-rust-5b993d10032651fd501d18cc4e60acca2fa33a46.tar.gz
-2643b73e433fd49f4e3156f071f0d320e5192362fc4b6ecc743d64ef72ad8eeff2e21f6ecd1a3c99864cfb9cbe496867fcd61978e3e8dca5ac8dfdd6ef5a56d8 update-deps.patch
+94c4b8ee05ff39d4a96d72198d620fb5ab088cc03cfab81a273fd7aa3b956e55914d1231a03c64d1d80c72d1674391f4c512b1a2273bddf6b94f3891decd6f41 keepassxc-proxy-rust-0.2.0.tar.gz
3d31ed8d2a430f1e61960990128a9b7277106fcf74c16952ccefdeca3a3ba5cb9e6917d08d801bff1d4d354566689bda8f54d10f3711b03063d01374913c0387 keepassxc-proxy-install.in
"