aboutsummaryrefslogtreecommitdiffstats
path: root/community/kemoticons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kemoticons/APKBUILD')
-rw-r--r--community/kemoticons/APKBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/community/kemoticons/APKBUILD b/community/kemoticons/APKBUILD
deleted file mode 100644
index 49de626beeb..00000000000
--- a/community/kemoticons/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=kemoticons
-pkgver=5.90.0
-pkgrel=0
-pkgdesc="Support for emoticons and emoticons themes"
-arch="all !armhf"
-url="https://community.kde.org/Frameworks"
-license="LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
-depends_dev="
- karchive-dev
- kconfig-dev
- kcoreaddons-dev
- kservice-dev
- "
-makedepends="$depends_dev
- doxygen
- extra-cmake-modules
- qt5-qttools-dev
- "
-checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kemoticons-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc"
-
-build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_QCH=ON
- cmake --build build
-}
-
-check() {
- cd build
-
- # kemoticons-kemoticontest and kemoticons-ktexttohtmlplugintest are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "kemoticons-(kemoticon|ktexttohtmlplugin)test"
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-sha512sums="
-dfe75a697fd08ab5235ea8fb019c3eff0776cd631b5e51ec1c74aa732d527f97897e0574a9b84e3113d23803f6c6b7755d9c5d55a1a853563757c4062e00b6dd kemoticons-5.90.0.tar.xz
-"