aboutsummaryrefslogtreecommitdiffstats
path: root/community/kemoticons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kemoticons/APKBUILD')
-rw-r--r--community/kemoticons/APKBUILD48
1 files changed, 0 insertions, 48 deletions
diff --git a/community/kemoticons/APKBUILD b/community/kemoticons/APKBUILD
deleted file mode 100644
index c499064b898..00000000000
--- a/community/kemoticons/APKBUILD
+++ /dev/null
@@ -1,48 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=kemoticons
-pkgver=5.94.0
-pkgrel=0
-pkgdesc="Support for emoticons and emoticons themes"
-arch="all !armhf"
-url="https://community.kde.org/Frameworks"
-license="LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
-depends_dev="
- karchive-dev
- kconfig-dev
- kcoreaddons-dev
- kservice-dev
- "
-makedepends="$depends_dev
- doxygen
- extra-cmake-modules
- qt5-qttools-dev
- samurai
- "
-checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kemoticons-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc"
-
-build() {
- cmake -B build -G Ninja \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_QCH=ON
- cmake --build build
-}
-
-check() {
- cd build
-
- # kemoticons-kemoticontest and kemoticons-ktexttohtmlplugintest are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "kemoticons-(kemoticon|ktexttohtmlplugin)test"
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-1b8d34fb58ef6b8ba83cc13eac719143606d1011b39551513773e78f660a3c7c4f3ed3402cb68bac9c216275cba7c1fdf6fdf2d905d377f9bf79a1eeac850b46 kemoticons-5.94.0.tar.xz
-"