aboutsummaryrefslogtreecommitdiffstats
path: root/community/keysmith/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/keysmith/APKBUILD')
-rw-r--r--community/keysmith/APKBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/community/keysmith/APKBUILD b/community/keysmith/APKBUILD
index ec92799df42..931b04b2cef 100644
--- a/community/keysmith/APKBUILD
+++ b/community/keysmith/APKBUILD
@@ -1,38 +1,40 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=keysmith
-pkgver=21.08
+pkgver=24.02.2
pkgrel=0
pkgdesc="OTP client for Plasma Mobile and Desktop"
url="https://invent.kde.org/kde/keysmith"
arch="all !armhf"
license="GPL-3.0-or-later"
-depends="kirigami2"
+depends="kirigami"
makedepends="
extra-cmake-modules
kdbusaddons-dev
ki18n-dev
- kirigami2-dev
+ kirigami-dev
libsodium-dev
- qt5-qtbase-dev
- qt5-qtquickcontrols2-dev
- qt5-qtsvg-dev
+ qt6-qt5compat-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
subpackages="$pkgname-lang"
-source="https://download.kde.org/stable/plasma-mobile/$pkgver/keysmith-$pkgver.tar.xz"
+_repo_url="https://invent.kde.org/utilities/keysmith.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/keysmith-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
check() {
- cd build
-
- # oath-convert-timestep-counter is broken, https://invent.kde.org/utilities/keysmith/-/issues/22
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "oath-convert-timestep-counter"
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -40,5 +42,5 @@ package() {
}
sha512sums="
-444c8d02a3d1433ed20b9f23d30790936d971d021649d585200240b8cc81750e6220aab5cc9e76e8cf15d55557bf0ec0571715454528dd1bd09c631285c4c614 keysmith-21.08.tar.xz
+9ee1750d3160a286b617a2f575759022b245a393da8ac5d5bc00363f1fe7a4088d6d444ac67d61dae22a15744178cafe1b3252177ab8ba37c7171150d626319d keysmith-24.02.2.tar.xz
"