aboutsummaryrefslogtreecommitdiffstats
path: root/community/keysmith/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/keysmith/APKBUILD')
-rw-r--r--community/keysmith/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/keysmith/APKBUILD b/community/keysmith/APKBUILD
index 2b049eeb865..931b04b2cef 100644
--- a/community/keysmith/APKBUILD
+++ b/community/keysmith/APKBUILD
@@ -1,26 +1,30 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=keysmith
-pkgver=22.06
+pkgver=24.02.2
pkgrel=0
pkgdesc="OTP client for Plasma Mobile and Desktop"
url="https://invent.kde.org/kde/keysmith"
arch="all !armhf"
license="GPL-3.0-or-later"
-depends="kirigami2"
+depends="kirigami"
makedepends="
extra-cmake-modules
kdbusaddons-dev
ki18n-dev
- kirigami2-dev
+ kirigami-dev
libsodium-dev
- qt5-qtbase-dev
- qt5-qtquickcontrols2-dev
- qt5-qtsvg-dev
+ qt6-qt5compat-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
samurai
"
subpackages="$pkgname-lang"
-source="https://download.kde.org/stable/plasma-mobile/$pkgver/keysmith-$pkgver.tar.xz"
+_repo_url="https://invent.kde.org/utilities/keysmith.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/keysmith-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -30,8 +34,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -39,5 +42,5 @@ package() {
}
sha512sums="
-44b6363a7a09b361ebf9cb9a2c85cc10c0c1c0cc88c44fcf53c84a2d1125ed677e528a3a1d87737f10447809e778cb11878de501ce711b576643951ebd8153b2 keysmith-22.06.tar.xz
+9ee1750d3160a286b617a2f575759022b245a393da8ac5d5bc00363f1fe7a4088d6d444ac67d61dae22a15744178cafe1b3252177ab8ba37c7171150d626319d keysmith-24.02.2.tar.xz
"