aboutsummaryrefslogtreecommitdiffstats
path: root/community/keysmith/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/keysmith/APKBUILD')
-rw-r--r--community/keysmith/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/keysmith/APKBUILD b/community/keysmith/APKBUILD
index ab5fae79c26..2adceff3222 100644
--- a/community/keysmith/APKBUILD
+++ b/community/keysmith/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=keysmith
pkgver=22.04
-pkgrel=0
+pkgrel=1
pkgdesc="OTP client for Plasma Mobile and Desktop"
url="https://invent.kde.org/kde/keysmith"
arch="all !armhf"
@@ -17,13 +17,14 @@ makedepends="
qt5-qtbase-dev
qt5-qtquickcontrols2-dev
qt5-qtsvg-dev
+ samurai
"
subpackages="$pkgname-lang"
source="https://download.kde.org/stable/plasma-mobile/$pkgver/keysmith-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}