aboutsummaryrefslogtreecommitdiffstats
path: root/community/kfind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kfind/APKBUILD')
-rw-r--r--community/kfind/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/community/kfind/APKBUILD b/community/kfind/APKBUILD
index c23f91b9dd7..c7a86f29b58 100644
--- a/community/kfind/APKBUILD
+++ b/community/kfind/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kfind
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/utilities/kfind"
pkgdesc="Find Files/Folders"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -21,9 +23,9 @@ makedepends="
kwidgetsaddons-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kfind-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/utilities/kfind.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kfind-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -34,8 +36,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -43,5 +44,5 @@ package() {
}
sha512sums="
-ba2cc6b4c8b8e17d40eb8239e2bebace99577c7347a3ef7f79e825f0561cd9709f2a3b6582c15489c5380589f4a1deafd0030bd10b6f9c5f6208879e8d55985c kfind-22.04.2.tar.xz
+6095e9dc128bd703bd95425457fc361daa0cafb17fc261b76a7ccdc4d65b378f995bb62ca47e776ece1982f2d89bb8ef53a33c9a9511439b51581287183dd992 kfind-24.02.2.tar.xz
"