aboutsummaryrefslogtreecommitdiffstats
path: root/community/kfind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kfind/APKBUILD')
-rw-r--r--community/kfind/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/kfind/APKBUILD b/community/kfind/APKBUILD
index ecc9edf3faf..c7a86f29b58 100644
--- a/community/kfind/APKBUILD
+++ b/community/kfind/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kfind
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/utilities/kfind"
pkgdesc="Find Files/Folders"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -19,22 +21,22 @@ makedepends="
kio-dev
ktextwidgets-dev
kwidgetsaddons-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kfind-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/utilities/kfind.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kfind-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -42,5 +44,5 @@ package() {
}
sha512sums="
-047a6cb3a894f67fa3dfd85c3ee1394f0731f81eac66682c76fdcfa90512af0c9eafb9ab684fce79b61f3ebd4169b7e716bf16e957259e1bf90ed45a562e2cdb kfind-21.12.1.tar.xz
+6095e9dc128bd703bd95425457fc361daa0cafb17fc261b76a7ccdc4d65b378f995bb62ca47e776ece1982f2d89bb8ef53a33c9a9511439b51581287183dd992 kfind-24.02.2.tar.xz
"