aboutsummaryrefslogtreecommitdiffstats
path: root/community/kfourinline/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kfourinline/APKBUILD')
-rw-r--r--community/kfourinline/APKBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/community/kfourinline/APKBUILD b/community/kfourinline/APKBUILD
index 99b7c2a3826..b9fca2fb8a8 100644
--- a/community/kfourinline/APKBUILD
+++ b/community/kfourinline/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kfourinline
-pkgver=21.08.2
+pkgver=24.02.1
pkgrel=0
pkgdesc="A four-in-a-row game"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/kfourinline/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
@@ -21,16 +23,19 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kfourinline-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/kfourinline.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kfourinline-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -41,5 +46,5 @@ package() {
}
sha512sums="
-d7ddc3c2e6475a6c159c578a1258b6e1395b4c3444fcb37fcbe62910c8d1be3cc54e460eca17db8edf816d16b40a80d3f7443b130743618a7a6d71f012cf94bf kfourinline-21.08.2.tar.xz
+b31254857d33029c57da67756e1150c3a7741ff7a6ab6699ebc10f75b951bbd45927e7b791de85006b6721bb2724b1b50b572950f9b2bf8d7072429e00b8ac59 kfourinline-24.02.1.tar.xz
"