aboutsummaryrefslogtreecommitdiffstats
path: root/community/kfourinline/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kfourinline/APKBUILD')
-rw-r--r--community/kfourinline/APKBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/community/kfourinline/APKBUILD b/community/kfourinline/APKBUILD
index 8bb62135ad7..e53df49d309 100644
--- a/community/kfourinline/APKBUILD
+++ b/community/kfourinline/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kfourinline
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
pkgdesc="A four-in-a-row game"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/kfourinline/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
@@ -21,16 +23,19 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kfourinline-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/kfourinline.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kfourinline-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -41,5 +46,5 @@ package() {
}
sha512sums="
-fbf8548c236a8c59f60ae5083967c4d3ac11f25f8a203351883f441896c66918ce8b9dff3a8d9b58d553fddfda808c05b5cb197057e82d1c307974a9650c8d7d kfourinline-21.08.3.tar.xz
+45c51c291c308249940819ec3540971578b29ad5407205c37f87f8e6c84c9c77fa4f5a7fee1cc96f3a21078dfeee466def452cf619dfae28f955ad813b21b3fe kfourinline-24.02.2.tar.xz
"