aboutsummaryrefslogtreecommitdiffstats
path: root/community/kgeography/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kgeography/APKBUILD')
-rw-r--r--community/kgeography/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/kgeography/APKBUILD b/community/kgeography/APKBUILD
index 19c69b20d61..1d9f82c3362 100644
--- a/community/kgeography/APKBUILD
+++ b/community/kgeography/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kgeography
-pkgver=22.04.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://edu.kde.org/kgeography"
pkgdesc="Geography Trainer"
license="GPL-2.0-or-later"
@@ -20,12 +22,12 @@ makedepends="
kitemviews-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kgeography-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/kgeography.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kgeography-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -36,8 +38,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +46,5 @@ package() {
}
sha512sums="
-d54faadf9e3cf7ea537890528302988228a611c5472c42d55998b4012a620398b78708b67a9bebca710798390e49df213553db78c0794b575afa262b5c573203 kgeography-22.04.1.tar.xz
+6010f5883ca5866442e8aa13045e60f332d2fc81683fb85f7597f4e0c8fc83805236a494ef9d06b9f04101cfe31086ae950b22e3b263570e1b8ac5e079fc9a43 kgeography-24.02.2.tar.xz
"