aboutsummaryrefslogtreecommitdiffstats
path: root/community/kguiaddons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kguiaddons/APKBUILD')
-rw-r--r--community/kguiaddons/APKBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/community/kguiaddons/APKBUILD b/community/kguiaddons/APKBUILD
index 3fff6fcd4c1..534dff3097e 100644
--- a/community/kguiaddons/APKBUILD
+++ b/community/kguiaddons/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this apkbuild by some scripts for automation
+# group=kde-frameworks
pkgname=kguiaddons
-pkgver=5.87.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="Addons to QtGui"
# armhf blocked by extra-cmake-modules
@@ -9,22 +12,25 @@ arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
- qt5-qttools-dev
- qt5-qtwayland-dev
- qt5-qtx11extras-dev
+ plasma-wayland-protocols
+ qt6-qttools-dev
+ qt6-qtwayland-dev
wayland-dev
"
makedepends="$depends_dev
extra-cmake-modules
doxygen
+ graphviz
+ samurai
"
checkdepends="xvfb-run"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-bin"
+_repo_url="https://invent.kde.org/frameworks/kguiaddons.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kguiaddons-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -32,15 +38,18 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
-
package() {
DESTDIR="$pkgdir" cmake --install build
}
+bin() {
+ amove usr/bin/kde-geo-uri-handler
+ amove usr/share/applications
+}
+
sha512sums="
-7c4c9239717bc8a701898c13dcb020382afa89f19293be775d16b8ec30d97a3a7612404a8e4b448a09f4216a477859862ad8065f65e454374cfb7ab3b973bb54 kguiaddons-5.87.0.tar.xz
+16fc3f133af9e6f1890513fc1314d276fc6a9630526cf445cdcf3bf8ab9651a509617e77963892f42d034a9f9f6de3420e1c07bf5f398eb688bead7a87e0337f kguiaddons-6.0.0.tar.xz
"