aboutsummaryrefslogtreecommitdiffstats
path: root/community/kguiaddons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kguiaddons/APKBUILD')
-rw-r--r--community/kguiaddons/APKBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/community/kguiaddons/APKBUILD b/community/kguiaddons/APKBUILD
index fda2c82ccbf..505fd9be312 100644
--- a/community/kguiaddons/APKBUILD
+++ b/community/kguiaddons/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this apkbuild by some scripts for automation
+# group=kde-frameworks
pkgname=kguiaddons
-pkgver=5.97.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Addons to QtGui"
# armhf blocked by extra-cmake-modules
@@ -10,9 +13,8 @@ url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
plasma-wayland-protocols
- qt5-qttools-dev
- qt5-qtwayland-dev
- qt5-qtx11extras-dev
+ qt6-qttools-dev
+ qt6-qtwayland-dev
wayland-dev
"
makedepends="$depends_dev
@@ -22,8 +24,9 @@ makedepends="$depends_dev
samurai
"
checkdepends="xvfb-run"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-bin"
+_repo_url="https://invent.kde.org/frameworks/kguiaddons.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kguiaddons-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc"
build() {
cmake -B build -G Ninja \
@@ -35,14 +38,18 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+bin() {
+ amove usr/bin/kde-geo-uri-handler
+ amove usr/share/applications
+}
+
sha512sums="
-2c555df05c9ea550580f0c70549797cba9a6e032912866cd32db7d1ec31a42f7980675c1f386887c77e4f226afa564856849a0d548c39bc082751ed4016890d8 kguiaddons-5.97.0.tar.xz
+e4413c692099cc946c260917777fd57e0ffac9bb3a251b70653f7557c64889558a3565896b4c79643504549b29a8b87b28b8cd98bf7762cb4c7056c5e563b869 kguiaddons-6.1.0.tar.xz
"