aboutsummaryrefslogtreecommitdiffstats
path: root/community/khealthcertificate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/khealthcertificate/APKBUILD')
-rw-r--r--community/khealthcertificate/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/community/khealthcertificate/APKBUILD b/community/khealthcertificate/APKBUILD
index 0ed7035fffb..3d21ffbf2e0 100644
--- a/community/khealthcertificate/APKBUILD
+++ b/community/khealthcertificate/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=khealthcertificate
-pkgver=22.06
+pkgver=24.02.2
pkgrel=0
pkgdesc="Handling of digital vaccination, test and recovery certificates"
url="https://invent.kde.org/pim/khealthcertificate"
@@ -11,17 +14,19 @@ license="LGPL-2.0-or-later"
depends_dev="
karchive-dev
kcodecs-dev
- openssl-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- samurai
+ ki18n-dev
+ openssl-dev>3
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
zlib-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/plasma-mobile/$pkgver/khealthcertificate-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/pim/khealthcertificate.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/khealthcertificate-$pkgver.tar.xz"
options="!check" # No tests
build() {
@@ -37,5 +42,5 @@ package() {
}
sha512sums="
-7a25d4ff26c8c109405e7f25aa661781c9c40b4bcc61ab82bcefa429958e1f0725994b3daf6763ec432c0cb8aabda6d4568bbaf8a156f162172b9a304350e68d khealthcertificate-22.06.tar.xz
+c43a2dbdd496f2180af4806b5a1079587a7063bcd99916cbef5e9cf8597e608ba5fa1612a326a89d52c3d6bf9c807ffbb1270f010948c0c40cddd5942c9e15f5 khealthcertificate-24.02.2.tar.xz
"