aboutsummaryrefslogtreecommitdiffstats
path: root/community/khealthcertificate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/khealthcertificate/APKBUILD')
-rw-r--r--community/khealthcertificate/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/community/khealthcertificate/APKBUILD b/community/khealthcertificate/APKBUILD
index 1e4d6009b83..3d21ffbf2e0 100644
--- a/community/khealthcertificate/APKBUILD
+++ b/community/khealthcertificate/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=khealthcertificate
-pkgver=21.12
+pkgver=24.02.2
pkgrel=0
pkgdesc="Handling of digital vaccination, test and recovery certificates"
url="https://invent.kde.org/pim/khealthcertificate"
@@ -11,21 +14,24 @@ license="LGPL-2.0-or-later"
depends_dev="
karchive-dev
kcodecs-dev
- openssl-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ ki18n-dev
+ openssl-dev>3
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
zlib-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/plasma-mobile/$pkgver/khealthcertificate-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/pim/khealthcertificate.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/khealthcertificate-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -36,5 +42,5 @@ package() {
}
sha512sums="
-ca263dc5cbeca19e77b33cbbcc41c56b102e85710124ccd2356e2bfc62e57130d09b9ad168cabc31937f38a60ab90e7207f23417cf4c69521553a81bbd67f261 khealthcertificate-21.12.tar.xz
+c43a2dbdd496f2180af4806b5a1079587a7063bcd99916cbef5e9cf8597e608ba5fa1612a326a89d52c3d6bf9c807ffbb1270f010948c0c40cddd5942c9e15f5 khealthcertificate-24.02.2.tar.xz
"