aboutsummaryrefslogtreecommitdiffstats
path: root/community/khealthcertificate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/khealthcertificate/APKBUILD')
-rw-r--r--community/khealthcertificate/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/khealthcertificate/APKBUILD b/community/khealthcertificate/APKBUILD
new file mode 100644
index 00000000000..3d21ffbf2e0
--- /dev/null
+++ b/community/khealthcertificate/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
+pkgname=khealthcertificate
+pkgver=24.02.2
+pkgrel=0
+pkgdesc="Handling of digital vaccination, test and recovery certificates"
+url="https://invent.kde.org/pim/khealthcertificate"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
+license="LGPL-2.0-or-later"
+depends_dev="
+ karchive-dev
+ kcodecs-dev
+ ki18n-dev
+ openssl-dev>3
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ zlib-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
+ samurai
+ "
+subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/pim/khealthcertificate.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/khealthcertificate-$pkgver.tar.xz"
+options="!check" # No tests
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+c43a2dbdd496f2180af4806b5a1079587a7063bcd99916cbef5e9cf8597e608ba5fa1612a326a89d52c3d6bf9c807ffbb1270f010948c0c40cddd5942c9e15f5 khealthcertificate-24.02.2.tar.xz
+"