aboutsummaryrefslogtreecommitdiffstats
path: root/community/kholidays/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kholidays/APKBUILD')
-rw-r--r--community/kholidays/APKBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/community/kholidays/APKBUILD b/community/kholidays/APKBUILD
index 473e3717068..e3fa20672c5 100644
--- a/community/kholidays/APKBUILD
+++ b/community/kholidays/APKBUILD
@@ -1,27 +1,32 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kholidays
-pkgver=5.87.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="Support for icon themes"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf" # armhf blocked by qt6-qtdeclarative
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later"
depends_dev="
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kholidays-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kholidays.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kholidays-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -29,15 +34,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
-
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-d71ab5f3592d15237e0ab493e214782758f876a8b91924b4f9de02387e00136427d5973800f14e79010acaba2cae17ccd9d29a97930911ab0dcfb5bdb2331c4b kholidays-5.87.0.tar.xz
+8edcfd931c415abb721d2a5256d7ec9ca6bc99d138465dbe8b77db0ff6bc6cc4ec4246462a961e4f53ea84819a0130e6d8ecd9141b4ed6575fed36b1462efaac kholidays-6.0.0.tar.xz
"