aboutsummaryrefslogtreecommitdiffstats
path: root/community/kholidays/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kholidays/APKBUILD')
-rw-r--r--community/kholidays/APKBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/community/kholidays/APKBUILD b/community/kholidays/APKBUILD
index e019bf2fc11..3e8ce7cc5e5 100644
--- a/community/kholidays/APKBUILD
+++ b/community/kholidays/APKBUILD
@@ -1,20 +1,32 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kholidays
-pkgver=5.82.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Support for icon themes"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf" # armhf blocked by qt6-qtdeclarative
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later"
-depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kholidays-$pkgver.tar.xz"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kholidays.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kholidays-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -22,15 +34,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
-
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-902065bc4d1ea733d24adf349bc895020eb49ec1d3f98c3e8ef4a59e3d0c968e998081c7ff1a18466201372c6f51fa9ae251e747da1b959f696975c886a42306 kholidays-5.82.0.tar.xz
+d2f3f5c3039f2ee55292edc427da863b0dfb364c57f74aeebcb6c8a85664c58aedbc810f1daec08e905decc3037d373607b0cc40929347030c2d2fef504663ff kholidays-6.1.0.tar.xz
"