aboutsummaryrefslogtreecommitdiffstats
path: root/community/khotkeys/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/khotkeys/APKBUILD')
-rw-r--r--community/khotkeys/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/khotkeys/APKBUILD b/community/khotkeys/APKBUILD
index 53d27d57efa..bba173bca97 100644
--- a/community/khotkeys/APKBUILD
+++ b/community/khotkeys/APKBUILD
@@ -1,25 +1,23 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=khotkeys
-pkgver=5.18.4
-_pkgver=5.18.4.1
+pkgver=5.18.5
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://www.kde.org/workspaces/plasmadesktop/"
pkgdesc="Key Accelerator Application"
license="GPL-2.0-only AND LGPL-2.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev kglobalaccel-dev ki18n-dev kio-dev kxmlgui-dev kdelibs4support-dev kdbusaddons-dev kcmutils-dev plasma-framework-dev plasma-workspace-dev kdoctools-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/khotkeys-$_pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/khotkeys-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
options="!check" # No tests
-builddir="$srcdir/$pkgname-$_pkgver"
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make -C build
+ cmake --build build
}
check() {
@@ -28,7 +26,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" make -C build install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="9c290c75caf175e66b69f182cb81348d0926b03dd569533dd6da380c299d416fd42f06d6c18fc6791c913e31f955c9adc98c20215442d7d93561b9bdb278e36d khotkeys-5.18.4.1.tar.xz"
+sha512sums="67e5d904127764e89d4a5c5d1c5fcc6ff0070d2a298f1032189dd3e9e17246482431ae651869d157625fc81caedee2a897947a6cb0bbe7508b5d76c61f5fca85 khotkeys-5.18.5.tar.xz"