aboutsummaryrefslogtreecommitdiffstats
path: root/community/ki18n/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ki18n/APKBUILD')
-rw-r--r--community/ki18n/APKBUILD41
1 files changed, 27 insertions, 14 deletions
diff --git a/community/ki18n/APKBUILD b/community/ki18n/APKBUILD
index 35d45c00cd6..01254486c49 100644
--- a/community/ki18n/APKBUILD
+++ b/community/ki18n/APKBUILD
@@ -1,20 +1,35 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=ki18n
-pkgver=5.87.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Advanced internationalization framework"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-or-later)"
-depends_dev="qt5-qtdeclarative-dev qt5-qtscript-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/ki18n-$pkgver.tar.xz"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
+ doxygen
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
+checkdepends="xvfb-run"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/ki18n.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/ki18n-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -22,16 +37,14 @@ build() {
}
check() {
- cd build
- # ki18n-klocalizedstringtest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "ki18n-klocalizedstringtest"
+ # kcountrytest, kcountrysubdivisiontest, kcatalogtest and ktimezone are broken
+ xvfb-run ctest --test-dir build --output-on-failure -E "(kcountry|kcountrysubdivision|kcatalog|ktimezone)test"
}
-
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-3b6420de995d6ed64a57934c16334fc48bdd495e81d5b64c15d2403c82fcbab21601d831d9b802b61af64b88c16281a50c8d689069bb3a92467c963cb6e9a0ac ki18n-5.87.0.tar.xz
+2f748d813a5b185b0f14932b589be6926b456c693d80e6f6dac1b15b91f5160001f426df833bac67147b9796874b723bf224206960d228561ff6bfd0a9b04cac ki18n-6.1.0.tar.xz
"