aboutsummaryrefslogtreecommitdiffstats
path: root/community/ki18n/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ki18n/APKBUILD')
-rw-r--r--community/ki18n/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/community/ki18n/APKBUILD b/community/ki18n/APKBUILD
index 24a8b111e7d..01254486c49 100644
--- a/community/ki18n/APKBUILD
+++ b/community/ki18n/APKBUILD
@@ -1,30 +1,35 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=ki18n
-pkgver=5.90.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Advanced internationalization framework"
-# armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt6-qtdeclarative
arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-or-later)"
depends_dev="
- qt5-qtdeclarative-dev
- qt5-qtscript-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
"
makedepends="$depends_dev
extra-cmake-modules
doxygen
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/ki18n-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/ki18n.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/ki18n-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -32,16 +37,14 @@ build() {
}
check() {
- cd build
- # ki18n-klocalizedstringtest, kcountrytest and kcountrysubdivisiontest are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(ki18n-klocalizedstring|kcountry|kcountrysubdivision)test"
+ # kcountrytest, kcountrysubdivisiontest, kcatalogtest and ktimezone are broken
+ xvfb-run ctest --test-dir build --output-on-failure -E "(kcountry|kcountrysubdivision|kcatalog|ktimezone)test"
}
-
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-4af602314692c53d3e040d0aec5b5952b7840f4e2a18d5126d347ee2ef6e7e42e4afecc7201ed8c3250ba9132f7078ebb6cbd110ca425109db1e99c5f06afab8 ki18n-5.90.0.tar.xz
+2f748d813a5b185b0f14932b589be6926b456c693d80e6f6dac1b15b91f5160001f426df833bac67147b9796874b723bf224206960d228561ff6bfd0a9b04cac ki18n-6.1.0.tar.xz
"