aboutsummaryrefslogtreecommitdiffstats
path: root/community/ki18n/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ki18n/APKBUILD')
-rw-r--r--community/ki18n/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/ki18n/APKBUILD b/community/ki18n/APKBUILD
index 1e643d9600a..01254486c49 100644
--- a/community/ki18n/APKBUILD
+++ b/community/ki18n/APKBUILD
@@ -1,27 +1,31 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=ki18n
-pkgver=5.94.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Advanced internationalization framework"
-# armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt6-qtdeclarative
arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-or-later)"
depends_dev="
- qt5-qtdeclarative-dev
- qt5-qtscript-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
"
makedepends="$depends_dev
extra-cmake-modules
doxygen
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/ki18n-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/ki18n.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/ki18n-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -33,9 +37,8 @@ build() {
}
check() {
- cd build
- # ki18n-klocalizedstringtest, kcountrytest and kcountrysubdivisiontest are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(ki18n-klocalizedstring|kcountry|kcountrysubdivision)test"
+ # kcountrytest, kcountrysubdivisiontest, kcatalogtest and ktimezone are broken
+ xvfb-run ctest --test-dir build --output-on-failure -E "(kcountry|kcountrysubdivision|kcatalog|ktimezone)test"
}
package() {
@@ -43,5 +46,5 @@ package() {
}
sha512sums="
-ff00a56f1d6e5a425d025320be6f6e1559e329f56e68975df9d7c1ecdc0108f2118af37373db583d7760f34877bd0f18bef47080a70dfca628d958f35e8f9e15 ki18n-5.94.0.tar.xz
+2f748d813a5b185b0f14932b589be6926b456c693d80e6f6dac1b15b91f5160001f426df833bac67147b9796874b723bf224206960d228561ff6bfd0a9b04cac ki18n-6.1.0.tar.xz
"