aboutsummaryrefslogtreecommitdiffstats
path: root/community/kiconthemes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kiconthemes/APKBUILD')
-rw-r--r--community/kiconthemes/APKBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/community/kiconthemes/APKBUILD b/community/kiconthemes/APKBUILD
index dd6b8cc08de..d91ffef94f3 100644
--- a/community/kiconthemes/APKBUILD
+++ b/community/kiconthemes/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks-old
pkgname=kiconthemes
-pkgver=5.90.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Support for icon themes"
# armhf blocked by extra-cmake-module
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only"
depends_dev="
@@ -16,20 +18,22 @@ depends_dev="
ki18n-dev
kitemviews-dev
kwidgetsaddons-dev
- qt5-qtsvg-dev
+ qt6-qtsvg-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kiconthemes-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kiconthemes.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kiconthemes-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -37,9 +41,10 @@ build() {
}
check() {
- cd build
- # kiconloader_unittest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(kiconloader_unittest|kiconloader_resourcethemetest)"
+ case "$CARCH" in
+ s390x) xvfb-run ctest --test-dir build --output-on-failure -E "kicon(engine|loader)_unittest" ;;
+ *) xvfb-run ctest --test-dir build --output-on-failure -E "kiconengine_unittest" ;;
+ esac
}
package() {
@@ -47,5 +52,5 @@ package() {
}
sha512sums="
-91a281df7c0336b1358969d0c6ef2899679e1b0088d74f5ad5c02ddcc9d0e0bfc71ea6fe13eec6ba6668996128ef6d175b94ae46388327534a28f851eae99998 kiconthemes-5.90.0.tar.xz
+a0f0210be8e464518770762f99d072c688872d2b9f324fa12830bdee78c9cf9439514b83ce87a6e526815dd7fbeaa76b6027a0c5cff6119052ccbac8ec8635c2 kiconthemes-6.1.0.tar.xz
"