aboutsummaryrefslogtreecommitdiffstats
path: root/community/kidletime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kidletime/APKBUILD')
-rw-r--r--community/kidletime/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/kidletime/APKBUILD b/community/kidletime/APKBUILD
index 75db1580973..5d1aaeeab11 100644
--- a/community/kidletime/APKBUILD
+++ b/community/kidletime/APKBUILD
@@ -1,22 +1,29 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kidletime
-pkgver=5.97.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Monitoring user activity"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-only"
-depends_dev="qt5-qtx11extras-dev"
-makedepends="$depends_dev
+makedepends="
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ plasma-wayland-protocols
+ qt6-qttools-dev
+ qt6-qtwayland-dev
samurai
+ wayland-dev
+ wayland-protocols
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kidletime-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kidletime.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kidletime-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -28,10 +35,8 @@ build() {
}
check() {
- cd build
-
# solidmttest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "solidmttest"
+ ctest --test-dir build --output-on-failure -E "solidmttest"
}
package() {
@@ -39,5 +44,5 @@ package() {
}
sha512sums="
-1cb97c9a1ef2204c77b95dbe88f946bf22b3eeba69ff95c23dbc1fb6b250be83dc43b9e42b64e577525a726bc8d971d65f6d4ea94d88b8162cc196eb39264ed8 kidletime-5.97.0.tar.xz
+9a958ccfb6a0b4bb32b481279b9ca0f96ab84a9400ed68da7c3712fefec070983d9c00e29ed9f6a53409796f73db4e32c41ebe275dd51ece21b6b00044f94828 kidletime-6.1.0.tar.xz
"