aboutsummaryrefslogtreecommitdiffstats
path: root/community/kidletime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kidletime/APKBUILD')
-rw-r--r--community/kidletime/APKBUILD38
1 files changed, 26 insertions, 12 deletions
diff --git a/community/kidletime/APKBUILD b/community/kidletime/APKBUILD
index 292b87dbb01..5d1aaeeab11 100644
--- a/community/kidletime/APKBUILD
+++ b/community/kidletime/APKBUILD
@@ -1,20 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kidletime
-pkgver=5.84.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Monitoring user activity"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-only"
-depends_dev="qt5-qtx11extras-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kidletime-$pkgver.tar.xz"
+makedepends="
+ doxygen
+ extra-cmake-modules
+ plasma-wayland-protocols
+ qt6-qttools-dev
+ qt6-qtwayland-dev
+ samurai
+ wayland-dev
+ wayland-protocols
+ "
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kidletime.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kidletime-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -22,13 +35,14 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ # solidmttest is broken
+ ctest --test-dir build --output-on-failure -E "solidmttest"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-f6438322b11880d848a51f7b9ce152c0a2e3a4bb38611a8d4bc878a9f8fd685ab909c8015adac946754b9675846e4a22390c891ce808291b87fb4700cccfc683 kidletime-5.84.0.tar.xz
+9a958ccfb6a0b4bb32b481279b9ca0f96ab84a9400ed68da7c3712fefec070983d9c00e29ed9f6a53409796f73db4e32c41ebe275dd51ece21b6b00044f94828 kidletime-6.1.0.tar.xz
"