aboutsummaryrefslogtreecommitdiffstats
path: root/community/kidletime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kidletime/APKBUILD')
-rw-r--r--community/kidletime/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/kidletime/APKBUILD b/community/kidletime/APKBUILD
index 50d06d0c824..7a62e997d38 100644
--- a/community/kidletime/APKBUILD
+++ b/community/kidletime/APKBUILD
@@ -1,22 +1,29 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kidletime
-pkgver=5.95.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="Monitoring user activity"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-only"
-depends_dev="qt5-qtx11extras-dev"
-makedepends="$depends_dev
+makedepends="
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ plasma-wayland-protocols
+ qt6-qttools-dev
+ qt6-qtwayland-dev
samurai
+ wayland-dev
+ wayland-protocols
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kidletime-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kidletime.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kidletime-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -28,10 +35,8 @@ build() {
}
check() {
- cd build
-
# solidmttest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "solidmttest"
+ ctest --test-dir build --output-on-failure -E "solidmttest"
}
package() {
@@ -39,5 +44,5 @@ package() {
}
sha512sums="
-f7445c1d929b5e993731f64ad735aac22272b6cf4ffb6486879000392d8d00024d1c6c83937d1898a43d7f09bb4f547bf7e0332d2b3ea939e8978bdd9260778d kidletime-5.95.0.tar.xz
+cf33f722dc88962d72d8eaa51cf943028810024806e7610bbd23f3d2d523b7c99183227360528ea3a2f7c6ab017f315ddae33694377f3ba190adde611d7ea0f2 kidletime-6.0.0.tar.xz
"