aboutsummaryrefslogtreecommitdiffstats
path: root/community/kidletime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kidletime/APKBUILD')
-rw-r--r--community/kidletime/APKBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/community/kidletime/APKBUILD b/community/kidletime/APKBUILD
index e1085225aa9..7a62e997d38 100644
--- a/community/kidletime/APKBUILD
+++ b/community/kidletime/APKBUILD
@@ -1,25 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kidletime
-pkgver=5.87.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="Monitoring user activity"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-only"
-depends_dev="qt5-qtx11extras-dev"
-makedepends="$depends_dev
+makedepends="
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ plasma-wayland-protocols
+ qt6-qttools-dev
+ qt6-qtwayland-dev
+ samurai
+ wayland-dev
+ wayland-protocols
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kidletime-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kidletime.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kidletime-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -27,15 +35,14 @@ build() {
}
check() {
- cd build
-
# solidmttest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "solidmttest"
+ ctest --test-dir build --output-on-failure -E "solidmttest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-429f56b63daabc3d9a367dfeff348df08017e43c62d4a2e3d0922d7e90681eadf9dcc2c1f5c5808a27ecae098f35aae651a5c278fc16c1bb4fb447e8aad26284 kidletime-5.87.0.tar.xz
+cf33f722dc88962d72d8eaa51cf943028810024806e7610bbd23f3d2d523b7c99183227360528ea3a2f7c6ab017f315ddae33694377f3ba190adde611d7ea0f2 kidletime-6.0.0.tar.xz
"