aboutsummaryrefslogtreecommitdiffstats
path: root/community/kig/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kig/APKBUILD')
-rw-r--r--community/kig/APKBUILD48
1 files changed, 25 insertions, 23 deletions
diff --git a/community/kig/APKBUILD b/community/kig/APKBUILD
index 921b1d2df1b..c32fdf56dd7 100644
--- a/community/kig/APKBUILD
+++ b/community/kig/APKBUILD
@@ -1,44 +1,46 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kig
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
-# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
-url="http://edu.kde.org/kig"
pkgdesc="Interactive Geometry"
+url="https://edu.kde.org/kig"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- karchive-dev
- kconfigwidgets-dev
- kcoreaddons-dev
- kcrash-dev
- kdoctools-dev
- ki18n-dev
- kiconthemes-dev
- kparts-dev
- ktexteditor-dev
- kxmlgui-dev
+ karchive5-dev
+ kconfigwidgets5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kparts5-dev
+ ktexteditor5-dev
+ kxmlgui5-dev
qt5-qtbase-dev
qt5-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kig-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/kig.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kig-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +48,5 @@ package() {
}
sha512sums="
-f82695722fb66a707abaf120b56e0f0977a63065a21849e72f178ee0eb653b73bd5ceb651a92085a34ad7d1c98da08611138a7d52b491c7caa9cbca47b7ff19e kig-21.04.3.tar.xz
+8757a335a85cf1439e7abc3abe55aca9d3dd8962c550ded953d79fe3a752770469e56300679ecf821262f2aef9be7e8e45093f47126f702823b6e654850deb1c kig-24.02.2.tar.xz
"